
 
 

Creating Accessible Documents 

When you create documents – regardless of the program you are using – it is important to 
ensure that people with disabilities can read them. All content and documents (HTML, PDF, 
Word, etc.) posted to UB websites must meet minimum accessibility standards, which allow 
screen readers or other assistive devices to properly read the files. 

Although it is sometimes possible to fix a PDF after you create it, it is far better – and usually 
easier – to address accessibility in the source document as you create it. 

The following best practices will help you increase the accessibility of your documents. 

• Use headings 
• Use lists 
• Add alternative text to images 
• Use tables appropriately and effectively 
• Write descriptive link text 
• Set document language 
• Set document properties 
• Understand how to export to PDF while preserving accessibility 
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Headings 

Proper headings convey content hierarchy and form an outline of the page content. Be sure 
to use the built-in heading tools in the program you are using. Do not simply change text size 
and weight. Stylistic changes (e.g., using bold or changing font size) do not provide adequate 
document structure needed for assistive technology. Be sure to include at minimum one 
heading level 1 in your document. 

Six levels of headings convey higher and lower levels of content hierarchy: 

• Heading 1: Usually a page title or a main content heading. It is the most important 
heading, and there is generally just one. 

• Heading 2: Usually a major section heading. 
• Heading 3: Usually a sub-section of the heading 2. 
• Heading 4: Usually a sub-section of the heading 3, and so on, ending with heading 6. 

Example heading structure: 

Heading 1 
 Heading 2 
 Heading 2 

 Heading 3 
 Heading 3 

 Heading 2 
 Heading 3 
 Heading 4 
 

Microsoft Word 

1. Select the text you want to use as a heading. 
2. On the Home ribbon, select the heading style you want to use. If you 

hover over the style, you can see what it looks like. 
3. To see additional styles, click the down arrow to expand the options 

available. 
4. To modify an existing style, expand the styles window and select 

Manage Styles. To add a new style, expand the styles window and 
select New Style. (Additional help with managing and adding styles in 
Microsoft Word.) 

https://support.office.com/en-us/article/customize-or-create-new-styles-in-word-d38d6e47-f6fc-48eb-a607-1eb120dec563
https://support.office.com/en-us/article/customize-or-create-new-styles-in-word-d38d6e47-f6fc-48eb-a607-1eb120dec563
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Lists 

Lists add important semantic and hierarchical structure to your documents. There are two 
types of lists: ordered and unordered.  

Use ordered lists to present a group of items that follow a numerical or alphabetical 
sequence. For example: 

1. Complete orientation data form. 
2. Submit immunization records. 
3. Register for classes. 
4. Attend orientation. 

Use unordered lists to present a group of bulleted items that do not follow a sequence. For 
example: 

• Time management. 
• Test taking. 
• Study skills. 
• Academic planning. 

Use the bullet or numbering tools in your program to create lists. Simply indenting a list does 
not provide the necessary document structure, making it more difficult for screen reader users 
to understand. 
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Alternative text for images 

Alternative text (alt text) is a non-visual representation of the content or function of an image. 
All images must have alt text. 

According to WebAIM, alternative text serves several functions: 

• It is read by screen readers in place of images, allowing the content and function of 
the image to be accessible to those with visual or certain cognitive disabilities. 

• It is displayed in place of the image in browsers if the image file is not loaded or when 
the user has chosen not to view images. 

• It provides a semantic meaning and description to images that can be read by search 
engines or be used to later determine the content of the image from page context 
alone. 

Writing alternative text can be a bit of an art, but it is not impossible. Follow these tips when 
writing your alt text: 

• Provide meaningful information about what is in the image and accurately describe 
the purpose of the image to the user.  

• If the image is also a link, summarize the function of the link in the alt text.  
• Include any text that is in the image in the alt text. 
• Avoid using words like “photo of” or “image of” in your alt text. 
• Ask yourself what you would want to know about the image if you could not see it.  

Decorative images (e.g., bullets, icons, background images, etc.) do not require descriptive alt 
text but do require a null alt text, written as “”. 

 

Microsoft Word 

1. Add your image to the document. 
2. Right click the image. 
3. Select Format Picture. 
4. Click the icon for Layout & Properties and select Alt Text 
5. Add your full alt text in the Description field (or for a decorative image 

only, type “”).  

Microsoft PowerPoint 

1. Add your image to the document. 
2. Right click the image. 
3. Select Format Picture. 
4. Click the icon for Size & Properties and select Alt Text. 

https://webaim.org/techniques/alttext/
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5. Add your full alt text in the Description field (or for a decorative image 
only, type “”).  

Note: Unless you have a complex chart, you will usually want to enter text in just the 
Description box. When you have complex content to describe, then filling in the Title field is 
useful so reading the full description is not necessary unless desired. 

Additional help with adding alt text in other versions of Microsoft products. 

Tables 

Tables organize information and display relationships between data. Avoid using tables solely 
for layout, and strive to make your tables as simple as possible. If you have a complex set of 
data to display, consider creating more than one table.  

Use the built-in table tools in your program to create tables.  

 

Microsoft Word 

1. Click Insert > Table and move your cursor over the grid to select the 
number of columns and rows you want. 

2. Identify the row that contains the column headers: 
a. Select the row (Table Tools > Select > Row). 
b. Right click the row and select Table Properties. 
c. Click the Row tab. 
d. Check the checkbox that says “Repeat as header row at top of 

each page”. 

  

https://support.office.com/en-us/article/add-alternative-text-to-a-shape-picture-chart-smartart-graphic-or-other-object-44989b2a-903c-4d9a-b742-6a75b451c669
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Links 

When you include links to websites in your documents, write link text so it makes sense to 
users. Link text should be descriptive enough that it can stand on its own. Avoid the use of 
phrases like “click here,” “learn more,” “here,” “more,” “link to,” etc. Also, avoid using the URL of 
a webpage as the link text. 

 

Instead of: “Use this link to view our academic programs.” 

write: “Explore our academic programs.” 

Instead of: “Click here for a list of academic advisors”  

write: “Find your advisor in the academic advisor directory.” 

Instead of: “Visit our website at 
https://www.buffalo.edu/cpmc/about/experiential-learning-
award/experiential-learning-award-application.html to apply 
for the scholarship.”  

write: “Apply for the Experiential Learning Award.” 

  

https://catalog.buffalo.edu/academicprograms/
https://catalog.buffalo.edu/academicprograms/
https://advising.buffalo.edu/directory/index.php
https://advising.buffalo.edu/directory/index.php
https://www.buffalo.edu/cpmc/about/experiential-learning-award/experiential-learning-award-application.html
https://www.buffalo.edu/cpmc/about/experiential-learning-award/experiential-learning-award-application.html
https://www.buffalo.edu/cpmc/about/experiential-learning-award/experiential-learning-award-application.html
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Document language 

Every document must specify a language so assistive technology knows in what language to 
read it. 

Document properties 

Document properties, also known as metadata, are details about the file that describe or 
identify it. Every PDF requires a minimum set of document properties. Similar to other 
elements of accessible documents, it is most efficient to set your document properties in the 
source document prior to converting to a PDF. 

 

Microsoft Word 

1. Click File tab. 
2. On the Info screen, you will see Properties in the right column. 
3. Click on “Show All Properties” at the end of the right column. 
4. Complete the following information: 

o Title: This is the title of the document. 
o Tags: Include keywords about the subject of the document. 
o Subject: Include a brief description of the document, being careful 

not to repeat the title. 
o Company: This should always be University at Buffalo. 
o Author: This should not be an individual person’s name. Instead, this 

filed should say University at Buffalo and include your department 
name. For example, “University at Buffalo Office of the Registrar.” 

Microsoft Publisher 

1. Click File tab. 
2. On the Info screen, you will see Publication Properties in the right 

column. 
3. Click the down arrow next to Publication Properties and select 

Advanced Properties. 
4. Click on the Summary tab and complete the following information: 

o Title: This is the title of the document. 
o Subject: Include a brief description of the document, being careful 

not to repeat the title. 
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o Author: This should not be an individual person’s name. Instead, this 
filed should say University at Buffalo and include your department 
name. For example, “University at Buffalo Office of the Registrar”. 

o Company: This should always be University at Buffalo. 
o Keywords: Include keywords about the subject of the document. 

PowerPoint 

We never recommend posting a PowerPoint file on a website. In the event you 
absolutely need to post a slideshow, you should convert it to a PDF prior to 
posting.  

Converting to PDF 

When you create a PDF from your source document, you must ensure that you preserve 
accessibility and ensure that your PDF is tagged. Tags in PDFs provide a hidden structured, 
textual representation of the content (WebAIM). 

Many PDFs start as Microsoft Word documents. Microsoft Office provides tools to create 
accessible PDFs, provided that your original document is accessible.  

1. Go to File > Check for Issues > Check for Accessibility. 
(In newer versions of Word, look for this under the Review tab.) 

2. Results of the check will display on the right side of your document. 
3. Be sure to fix all errors. 

Please note: Never print to PDF. Doing so does not preserve the document’s accessibility 
features.  

 

Microsoft Word 2013 and 2010 

1. Go to File > Save As Adobe PDF. 
2. Select Options in the save screen and check the following: 

a. Convert document information. 
b. Enable Accessibility and Reflow with tagged Adobe PDF. 

3. Name your file and save it. 

 

  

https://webaim.org/techniques/acrobat/
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Verify PDF Accessibility 

After you create your PDF, take time to evaluate the accessibility of your PDF using Adobe 
Acrobat DC. You can use Adobe Reader minimally to verify that the document properties 
have been saved to the PDF, but the best way to evaluate and enhance the accessibility of 
your PDF is by using Adobe Acrobat DC.  

1. Choose Tools > Accessibility. 
2. In the secondary toolbar, click Full Check. 
3. In Report Options, select options for how you want to view the report. You can save 

the results as an HTML file or attach the results to the document. 
4. Select one or more of the Checking Options. We suggest selecting all of the options 

under each category (Document; Page content; Forms, Tables and Lists; and Alternate 
Text and Headings). 

5. Click Start Checking. 
6. The resulting report will display the status of each of the accessibility rules checked. 

• A green checkmark means your 
document passed that rule. 

• You must manually review and 
correct or pass rules with blue 
question marks. 

• Red Xs are errors. You must fix 
each of these in order to have a 
fully accessible PDF.  
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